Hey the forum thinger is busted! Issues known and found.

There are too many subforums. Please eliminate three.
Post Reply
Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Thu Dec 07, 2017 6:54 pm

ComradeCosmobot wrote:
Mon Dec 04, 2017 8:52 pm
Nothing I can do about this. The Notifications link is supposed to actually link you to your notifications page, but the click event gets consumed before that happens. However, the click does screw with the hover events such that they can’t come back.

There may be some JavaScript error that kills event handling on the page, but so far I haven’t found it or found a way to fix it. Even adding onclick event handlers and using them to suppress the event before it hits the actual link doesn’t prevent the drop down from being permanently disabled.
There's supposed to be a way to recognize clicks as being distinct from taps, for sites that need the hover behavior to be available for mobile users (just today, I witnessed this on Steam Workshop—tap a thumbnail once and you get the pop-up info box that normally appears when you hover; tap again and it follows the link), but this might only work if the hover is handled by pure CSS, or maybe only if it isn't.

If all else fails, you should consider it a bug and submit a bug report to the PHPBB guys, because making a feature that straight-up doesn't function on touch devices in 2017 is unacceptable.

West Filly
User avatar
Stare Masters
Posts: 767
Joined: Tue Oct 31, 2017 6:46 am
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by West Filly (?) » Wed Dec 13, 2017 10:02 am

West Filly wrote:
Thu Dec 07, 2017 6:15 pm
The "mark all topics read" link is where the "view unread topics" link used to be :gonkity:
This is actually pissing me off now. I go to click for the unread topics and what happens is they all get marked read instead.
👉👉🥜🏠

West Filly
User avatar
Stare Masters
Posts: 767
Joined: Tue Oct 31, 2017 6:46 am
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by West Filly (?) » Thu Dec 14, 2017 8:24 am

AUGH.
👉👉🥜🏠

Jill
User avatar
it's the super maria sisters super show!!!
Special Flowers
Posts: 388
Joined: Mon Oct 30, 2017 10:59 pm
Gender: Female
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Jill (?) » Fri Dec 15, 2017 7:48 am

twitter embeds seem to have broken for me and get stuck at "loading tweet", so i have to right click and open their URL in a new tab

RIP Syndrome
User avatar
You fail to perceive this bizarre cosmos in a manner similar to my own
Rainbow Racers
Posts: 111
Joined: Tue Oct 31, 2017 6:56 am
Location: Scunthorpe 2

Re: Hey the forum thinger is busted! Issues known and found.

Post by RIP Syndrome (?) » Fri Dec 15, 2017 8:38 am

Are you using Firefox and specifically private browsing mode or have tracking protection enabled? Because that will break Twitter embeds.
Image
this post and you´re face ™&©20201 R.I.P. Shitpostal Service LLC
for licensing inquiries, please contact :twisted:, VP of Licensing at R.I.P. Enterprises
~ORIGINAILL COUNTENTEH SINCE 1666 DONTE is good STEEL PLS~

Jill
User avatar
it's the super maria sisters super show!!!
Special Flowers
Posts: 388
Joined: Mon Oct 30, 2017 10:59 pm
Gender: Female
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Jill (?) » Fri Dec 15, 2017 9:27 am

no, Chrome. the problem seems to have fixed itself after a few hours so it may have been something on Twitter's end

RIP Syndrome
User avatar
You fail to perceive this bizarre cosmos in a manner similar to my own
Rainbow Racers
Posts: 111
Joined: Tue Oct 31, 2017 6:56 am
Location: Scunthorpe 2

Re: Hey the forum thinger is busted! Issues known and found.

Post by RIP Syndrome (?) » Fri Dec 15, 2017 9:45 am

Yeah that's the other possibility. Twitter's API stops embedding at random by design, and I think there's some sort of daily limit that might be domain specific or then it might just be all embeds anywhere. Either way once it reaches that threshold the embeds stop loading.
Image
this post and you´re face ™&©20201 R.I.P. Shitpostal Service LLC
for licensing inquiries, please contact :twisted:, VP of Licensing at R.I.P. Enterprises
~ORIGINAILL COUNTENTEH SINCE 1666 DONTE is good STEEL PLS~

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Sat Dec 16, 2017 9:52 am

If anyone was getting an error when they tried to search and view results as topics, that's fixed now.

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Sun Dec 17, 2017 10:04 pm

There's an issue with emails going out. Some providers aren't letting them be delivered anymore. Working on getting them sent through Amazon so they register as legit.

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Mon Dec 18, 2017 8:37 pm

Email notifications should be working again. If anyone isn't getting theirs, let me know so I can bang my head against the wall some more I can investigate further.

Big Boss
User avatar
A tourist trap that can surpass Mystery Shack?
Rarity's Roughnecks
Posts: 105
Joined: Sat Oct 28, 2017 5:55 pm
Gender: Male
Location: Mother Base

Re: Hey the forum thinger is busted! Issues known and found.

Post by Big Boss (?) » Wed Dec 20, 2017 2:22 pm

An FYI, services like HideHost are banned from the forum. Don't register using them, because you won't get in.

Marioland1
User avatar
Magikal Horse
Posts: 9
Joined: Sat Dec 16, 2017 12:19 am
Gender: Male
Location: An Anime TTT Server

Re: Hey the forum thinger is busted! Issues known and found.

Post by Marioland1 (?) » Mon Jan 01, 2018 11:47 pm

Image
The categories in the popout smiley thing are white in Play, just like the background of the category selector. This might apply to other dark themes too, as I know a few other darker themes had issues with white text on white backgrounds earlier in their remade iterations, so the same fix likely applies here too.

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Sat Jan 06, 2018 10:35 pm

Image

Avatars still have this large clickable whitespace around them and fixing this is all I ask for in 2018.

diribigal
User avatar
Special Flowers
Posts: 174
Joined: Tue Oct 31, 2017 6:35 am
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by diribigal (?) » Sun Feb 18, 2018 8:55 am

I came here to post about notifications not working on mobile (already discussed) and my personal issue that Twitter embeds never work. The solution to the latter was to change my ghostery's (aggressive blocker extension) settings to allow Twitter.
ImageImageImage Very math.

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Thu Mar 15, 2018 10:44 pm

I can no longer search for an entire phrase in quotes. Did the syntax change or something?

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Fri Mar 16, 2018 12:11 am

Unfortunately that was one of the things that broke in the migration to the new phpBB. It's a bug (or oversight, or something) in how phpBB handles the search backend we use.

As a workaround, you can google for site:roundstable.com and your phrase in quotes.

Aria Genisi
User avatar
Now THIS is 2021!
Night Mares
Posts: 332
Joined: Mon Oct 30, 2017 11:45 pm
Gender: Female
Location: Michigan
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Aria Genisi (?) » Mon Apr 02, 2018 10:40 pm

Tweets don't seem to be loading properly with the [media] tag?

Like, for example, in the simpsons memes thread over in PPPP, the last two posts should include two tweets in there, but currently for me, they show up like this:

Image
Image

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Mon Apr 02, 2018 10:46 pm

Are you using ublock? It's started blocking our media extension for some reason. Whitelist the forums since we don't have ads anyways.

Aria Genisi
User avatar
Now THIS is 2021!
Night Mares
Posts: 332
Joined: Mon Oct 30, 2017 11:45 pm
Gender: Female
Location: Michigan
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Aria Genisi (?) » Mon Apr 02, 2018 10:50 pm

Huh. yeah, apparently it was ublock. Weird.

Thanks for the help though, it's working fine now.
Image

Perrydotto
User avatar
Agents of Chaos
Posts: 1271
Joined: Sun Oct 29, 2017 6:20 am
Gender: Female
Location: The Final Frontier

Re: Hey the forum thinger is busted! Issues known and found.

Post by Perrydotto (?) » Tue Apr 03, 2018 5:27 am

I had the same issue, I reckon all Ublock users will. Thanks for the headsup!
Image /// Image /// Image

Fizzbuzz
User avatar
Stare Masters
Posts: 1001
Joined: Sat Oct 28, 2017 10:54 pm
Gender: Male
Location: TN
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Fizzbuzz (?) » Tue Apr 03, 2018 8:03 am

Specifically, what's happening is that one of phpBB's developers uses GitHub to host and serve media embed scripts and HTML for various sites. One of uBlock Origin's default block lists recently decided that any embedded content hosted on github.io (basically, GitHub's public web server that each user can upload stuff to; think GeoCities but for the 21st century) needed to be blocked, which is why this broke all of a sudden.

So yeah, whitelist TRS.
Image

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Wed Apr 04, 2018 2:30 am

Because heaven forbid those scripts just be included in the package you get when you download or update PHPBB. It's fine; why would anything hosted offsite ever not work? :roll:

Madeline
User avatar
check out my kitty meow
Semper Pie
Posts: 984
Joined: Tue Mar 20, 2018 3:45 pm

Re: Hey the forum thinger is busted! Issues known and found.

Post by Madeline (?) » Sat Apr 21, 2018 6:51 am

Should https be enforced when you login? I ask because right now, in Safari on iOS, it defaults me back to http and I have to manually edit the url on the login page to do it securely. Once the cookie is set, it stays https for a while, but resets to http seemingly at random. I’m unsure if this is a Safari thing, or not.

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Fri May 04, 2018 9:31 pm

(1) Bold tags don't appear to be working in user titles anymore

(2) Twitter embeds don't work on tablets. This might be unavoidable, because Twitter insists on redirecting to its own mobile version.

Madeline
User avatar
check out my kitty meow
Semper Pie
Posts: 984
Joined: Tue Mar 20, 2018 3:45 pm

Re: Hey the forum thinger is busted! Issues known and found.

Post by Madeline (?) » Sun May 06, 2018 5:51 am

I’m on a tablet right now (iPad mini 2) and Twitter embeds still work for me in Safari. :ponder:

Screenshot:


Click for Fullsize

Venusy
User avatar
Stare Masters
Patreon supporter
Posts: 251
Joined: Tue Oct 31, 2017 2:02 am
Gender: Genderqueer
Location: Yorkshire, England
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Venusy (?) » Sun May 06, 2018 7:41 am

Yep, working fine for me on iOS 11.3 on my iPhone SE, so if this is a wider problem, it might be Android only?

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Wed May 09, 2018 2:57 am

Madeline wrote:
Sun May 06, 2018 5:51 am
I’m on a tablet right now (iPad mini 2) and Twitter embeds still work for me in Safari. :ponder:

Screenshot:


Click for Fullsize
Hmm. So it does. Must be some bizarre bug with Firefox then, although since the iOS version is just a Safari wrapper, I can't imagine how it could be. Also it looks like I can't tap links to Twitter either (although I can hold and open in a new tab), so the two are probably related. Gonna report this as a bug and see what happens.

Madeline
User avatar
check out my kitty meow
Semper Pie
Posts: 984
Joined: Tue Mar 20, 2018 3:45 pm

Re: Hey the forum thinger is busted! Issues known and found.

Post by Madeline (?) » Wed May 09, 2018 5:00 am

Pocket wrote:
Wed May 09, 2018 2:57 am
Hmm. So it does. Must be some bizarre bug with Firefox then, although since the iOS version is just a Safari wrapper, I can't imagine how it could be. Also it looks like I can't tap links to Twitter either (although I can hold and open in a new tab), so the two are probably related. Gonna report this as a bug and see what happens.
It's something weird, because I've been on Firefox on laptop tonight, and Twitter embeds weren't working for a while for me either. Then they suddenly did again. So I thought it might partially be due to Twitter's API as much as anything in PhpBB or Firefox, but who knows. I'm not very savvy with computers. :pinkieshrug:

Pocket
User avatar
As pure as driven-on snow
Posts: 346
Joined: Tue Nov 07, 2017 4:52 pm
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Pocket (?) » Fri May 25, 2018 3:29 am

Another CSS bug I caught: For some reason, the URL tag is set to display as inline-block, which prevents it from word-wrapping.

Mr. Big
User avatar
いいんですよ
Rarity's Roughnecks
Posts: 920
Joined: Mon Oct 30, 2017 11:00 pm
Gender: Male
Location: Tennessee
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Mr. Big (?) » Thu Jul 26, 2018 5:07 pm

Whenever I try to use the "media" bbcode, I get this error message:

Image

Void Chicken
User avatar
Stare Masters
Posts: 658
Joined: Sat Oct 28, 2017 6:14 pm
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by Void Chicken (?) » Thu Jul 26, 2018 7:03 pm

Mr. Big wrote:
Thu Jul 26, 2018 5:07 pm
Whenever I try to use the "media" bbcode, I get this error message:

Image
That's from the new mediaembed plugin. It gained the ability to give fine-grained permission to use it, and for some reason it defaulted to denying it. I thought I'd had it set up right, but PPPP has its own permission set, so I missed it. I set it there and hopefully I got everything now.

Mr. Big
User avatar
いいんですよ
Rarity's Roughnecks
Posts: 920
Joined: Mon Oct 30, 2017 11:00 pm
Gender: Male
Location: Tennessee
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Mr. Big (?) » Thu Jul 26, 2018 11:03 pm

Working now! Thanks!

CosmogenicLily
Site Admin
Posts: 112
Joined: Sun Oct 29, 2017 4:34 pm
Gender: Female

Re: Hey the forum thinger is busted! Issues known and found.

Post by CosmogenicLily (?) » Sat Aug 25, 2018 2:59 am

Did some maintenance on the old TRS server. As a result, some stuff broke, but it is now fixed:
  • Bronibooru
  • MLPonies.com redirect
Will probably also force SSL for all connections sometime in the next week.

Orange Fluffy Sheep
User avatar
Dropping tears does not always mean the sadness.
Rarity's Roughnecks
Posts: 485
Joined: Tue Oct 31, 2017 7:17 am
Gender: Male
Location: The hearts of man
Contact:

Re: Hey the forum thinger is busted! Issues known and found.

Post by Orange Fluffy Sheep (?) » Mon Aug 27, 2018 9:25 pm

Code: Select all

Error: PG::UndefinedFile: ERROR: could not access file "$libdir/test_parser": No such file or directory : SELECT "posts".* FROM "posts" WHERE (true) AND (posts.tag_index @@ to_tsquery('danbooru', E'(''vase'')')) ORDER BY posts.id DESC LIMIT 20 OFFSET 0

I ain't no wizard but it seems the search what a directory that is named danbooru by default, and bronibooru uh, ain't named that.
:snoop: Image :snoop:

CosmogenicLily
Site Admin
Posts: 112
Joined: Sun Oct 29, 2017 4:34 pm
Gender: Female

Re: Hey the forum thinger is busted! Issues known and found.

Post by CosmogenicLily (?) » Sat Sep 01, 2018 1:41 am

Nah, the error was the "$libdir/test_parser" thing. Apparently postgres 9.5 moved that out of the contrib package and made it a test-only fixture. I compiled it directly and dropped it back into place.

Also apparently the site was hitting the wrong postgres instance anyway, which should also now be fixed (although apparently pg_restore is hung for some reason?)

Gloomy Rube
User avatar
I want you to be like a hamster please
Celestia's Champions
Posts: 496
Joined: Tue Oct 31, 2017 2:36 am

Re: Hey the forum thinger is busted! Issues known and found.

Post by Gloomy Rube (?) » Sat Dec 01, 2018 2:21 pm

I'm somehow logged onto roundstable.com but not www.roundstable.com

how is this even possible
Image
ImageImageImageImage

Madeline
User avatar
check out my kitty meow
Semper Pie
Posts: 984
Joined: Tue Mar 20, 2018 3:45 pm

Re: Hey the forum thinger is busted! Issues known and found.

Post by Madeline (?) » Tue Dec 04, 2018 3:03 pm

Is SSL being forced yet? I still have to manually change the domain to https every time I get logged out and want to log back in.

RIP Syndrome
User avatar
You fail to perceive this bizarre cosmos in a manner similar to my own
Rainbow Racers
Posts: 111
Joined: Tue Oct 31, 2017 6:56 am
Location: Scunthorpe 2

Re: Hey the forum thinger is busted! Issues known and found.

Post by RIP Syndrome (?) » Sat Aug 17, 2019 6:39 am

Madeline wrote:
Tue Dec 04, 2018 3:03 pm
Is SSL being forced yet? I still have to manually change the domain to https every time I get logged out and want to log back in.
Yeah what's up with this? Is there any reason I still get redirected to the standard version and have to manually add in the https bit so I don't have to look at the THIS SITE IS UNSAFE warnings. Every other site has long since moved to https exclusively so I'd assume any potential breakage is probably pretty minimal at this point.
Image
this post and you´re face ™&©20201 R.I.P. Shitpostal Service LLC
for licensing inquiries, please contact :twisted:, VP of Licensing at R.I.P. Enterprises
~ORIGINAILL COUNTENTEH SINCE 1666 DONTE is good STEEL PLS~

diribigal
User avatar
Special Flowers
Posts: 174
Joined: Tue Oct 31, 2017 6:35 am
Gender: Male

Re: Hey the forum thinger is busted! Issues known and found.

Post by diribigal (?) » Mon Sep 30, 2019 5:24 am

For two admins and no other mods, I see dropdowns. Does that mean I can change what you two moderate?
ImageImageImage Very math.

SlateSlabrock
User avatar
Celestia's Champions
Patreon platinum
Posts: 461
Joined: Tue Oct 31, 2017 12:02 am

Re: Hey the forum thinger is busted! Issues known and found.

Post by SlateSlabrock (?) » Mon Sep 30, 2019 6:07 am

The menu items don't have any values, and I don't think there's any way to submit using them, so it probably just means they have a bunch of manually-assigned forum privileges instead of "everything".

Post Reply